Help Contact Toolbox My Profile Logout



You need to log in before you can work with e-pet.

Images may only be used in the artwork supplied and may not be extracted or used for any other purpose without prior authorization from the agency that supplied the original artwork.
I have read and understood the above.

User Name


Lost your password?

New User?

Problems logging in?

Welcome to e-pet the P&G Petcare online platform Toolbox
To work with e-pet, minimum software requirements are:

Internet Explorer 5.5 or higher, a video player and possibly additional plugins such as Adobe Acrobat Reader or Microsoft Office Viewers.

To download current versions follow the links.

Web Browsers
Internet Explorer

Video Players
Windows Media Player
Apple QuickTime

Adobe Acrobat Reader
Microsoft Office Viewers